[Resolved] Error adding UTM Grid

This topic contains 1 reply, has 2 voices, and was last updated by  TrueNorth 4 years, 1 month ago.

  • Author
    Posts
  • #505


    Ed Ehrler
    Participant

    Encounter the following error when attempting to add a UTM Grid Layer. Looking at the file paths it’s referring to I’m thinking it might be related to the installation error encountered earlier.

    Error message reads:

    Error Adding Layer

    System.InvalidOperationException: There is an error in XML document (1, 2). —> System.InvalidOperationException: <UTMGridSettingsType xmlns=’http://BlueToque.ca/TrueNorth/Grid/GridSettings’> was not expected.
    at Microsoft.Xml.Serialization.GeneratedAssembly.XmlSerializationReader1.Read67_GridSettings()
    — End of inner exception stack trace —
    at BlueToque.Utility.ExceptionManager.CriticalException(String formatString, Exception ex) in D:\Development\BlueToque-Dev\Libraries\BlueToque.Utility\BlueToque.Utility\ExceptionManager.cs:line 39
    at BlueToque.Utility.Serializer.Deserialize[T](TextReader reader, Type[] types, XmlReaderSettings settings) in D:\Development\BlueToque-Dev\Libraries\BlueToque.Utility\BlueToque.Utility\Serialization\Serializer.cs:line 296
    at BlueToque.Utility.Serializer.Deserialize[T](String xmlString, Type[] types) in D:\Development\BlueToque-Dev\Libraries\BlueToque.Utility\BlueToque.Utility\Serialization\Serializer.cs:line 169
    at BlueToque.Utility.Serializer.Deserialize[T](XmlElement element, Type[] types) in D:\Development\BlueToque-Dev\Libraries\BlueToque.Utility\BlueToque.Utility\Serialization\Serializer.cs:line 248
    at BlueToque.Utility.Serializer.Deserialize[T](XmlElement element) in D:\Development\BlueToque-Dev\Libraries\BlueToque.Utility\BlueToque.Utility\Serialization\Serializer.cs:line 140
    at BlueToque.Utility.Serializable`1.FromElement(XmlElement element) in D:\Development\BlueToque-Dev\Libraries\BlueToque.Utility\BlueToque.Utility\Serialization\Serializable.cs:line 201
    at TrueNorth.DefaultGrid.GridLayer.set_Any(XmlElement value) in c:\Development\TrueNorth2\TrueNorth\Plugins\TrueNorth.DefaultGrid\GridLayer.cs:line 70
    at TrueNorth.Data.LayerData.CreateLayer() in c:\Development\TrueNorth2\TrueNorth\TrueNorth.Data\LayerData.cs:line 98
    at TrueNorth2.UIManager.PromptForLayer() in c:\Development\TrueNorth2\TrueNorth\TrueNorth\UIManager.cs:line 237

  • #510


    TrueNorth
    Keymaster

    Hey!
    We’ve tracked down this bug and it will be fixed in the next release.
    It was related to an outdated file being included in the installation package.

The topic ‘Error adding UTM Grid’ is closed to new replies.